Export limit exceeded: 418227 CVEs match your query. Please refine your search to export 10,000 CVEs or fewer.
Export limit exceeded: 418227 CVEs match your query. Please refine your search to export 10,000 CVEs or fewer.
Search
Search Results (418227 CVEs found)
| CVE | Vendors | Products | Updated | CVSS v3.1 |
|---|---|---|---|---|
| CVE-2026-65627 | 1 Potatosalad | 1 Jose | 2026-11-02 | 7.5 High |
| Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in potatosalad jose (erlang-jose) allows a remote attacker to exhaust a node's memory with a small crafted JWE token. The jose_jwe_zip:uncompress/2 function in src/jwe/jose_jwe_zip.erl decompresses the DEFLATE-compressed plaintext of a JWE that carries the optional zip: DEF header by calling zlib:inflate/2 on the entire attacker-controlled stream, with no bound on the output size or the inflation ratio. Raw DEFLATE reaches ratios around 1000:1 on highly repetitive input, so a few-kilobyte token inflates to hundreds of megabytes or gigabytes in a single call. Decompression runs automatically during decryption through jose_jwe:block_decrypt/2 (JOSE.JWE.block_decrypt/2 in Elixir), before the recipient can inspect or reject the payload. With the common asymmetric key-management algorithms (RSA-OAEP, ECDH-ES) an attacker needs only the recipient's public key to craft such a token, so no authentication or secret material is required. A single small token can exhaust the node's memory and crash the BEAM, denying service to all users. This issue affects jose: from 1.0.0 before 1.11.13. | ||||
| CVE-2026-116768 | 1 Absolute | 1 Secure Access | 2026-11-02 | N/A |
| CVE-2026-116768 is a missing length validation vulnerability in Secure Access servers prior to 14.61. Authenticated attackers can cause a persistent denial of service when connecting for the first time. | ||||
| CVE-2026-116671 | 1 Xpdf | 1 Xpdf | 2026-11-02 | 5.5 Medium |
| Infinite loop in Xpdf 4.06 and earlier, due to incorrect validation of progression order field in JPEG 2000 image. | ||||
| CVE-2026-115748 | 1 Apache | 1 Vysper | 2026-11-02 | 8.8 High |
| **UNSUPPORTED WHEN ASSIGNED** Authorization bypass in Apache Vysper, all versions. Apache Vysper is an XMPP (Jabber) server library. Its XEP-0077 (In-Band Registration) implementation is missing an authentication check, allowing any authenticated user to compromise other accounts. As this project is retired, we do not plan to release a version that fixes this issue. Users are recommended to find an alternative. | ||||
| CVE-2026-115721 | 1 Apache | 1 Vysper | 2026-11-02 | 7.5 High |
| **UNSUPPORTED WHEN ASSIGNED** Unbounded allocation in XML parsing in Apache Vysper; all versions, may lead to an out of memory condition. This issue affects all versions of Apache Vysper. Apache Vysper is an XMPP (Jabber) server library. As this project is retired, we do not plan to release a version that fixes this issue. Users are recommended to find an alternative. | ||||
| CVE-2026-115418 | 1 Aws | 1 Aws-cdk Aws-redshift-alpha | 2026-11-02 | 7.3 High |
| SQL injection in the database-query custom resource handlers in the Amazon Web Services (AWS) Cloud Development Kit (CDK) @aws-cdk/aws-redshift-alpha module before 2.274.0-alpha.0 could allow a third party who can influence construct property values to run SQL statements with Amazon Redshift superuser privileges, including granting access to all cluster users. The statements are reachable through crafted user names, comments, or passwords. To remediate this issue, users should upgrade to version 2.274.0-alpha.0 or later and review existing table grants to PUBLIC. | ||||
| CVE-2022-3235 | 3 Debian, Fedoraproject, Vim | 3 Debian Linux, Fedora, Vim | 2026-11-02 | 7.8 High |
| Use After Free in GitHub repository vim/vim prior to 9.0.0490. | ||||
| CVE-2022-3234 | 3 Debian, Fedoraproject, Vim | 3 Debian Linux, Fedora, Vim | 2026-11-02 | 7.8 High |
| Heap-based Buffer Overflow in GitHub repository vim/vim prior to 9.0.0483. | ||||
| CVE-2022-3153 | 1 Vim | 1 Vim | 2026-11-02 | 5.5 Medium |
| NULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.0404. | ||||
| CVE-2022-3134 | 3 Debian, Neovim, Vim | 3 Debian Linux, Neovim, Vim | 2026-11-02 | 7.8 High |
| Use After Free in GitHub repository vim/vim prior to 9.0.0389. | ||||
| CVE-2022-3099 | 3 Debian, Fedoraproject, Vim | 3 Debian Linux, Fedora, Vim | 2026-11-02 | 7.8 High |
| Use After Free in GitHub repository vim/vim prior to 9.0.0360. | ||||
| CVE-2022-3037 | 3 Fedoraproject, Neovim, Vim | 3 Fedora, Neovim, Vim | 2026-11-02 | 7.8 High |
| Use After Free in GitHub repository vim/vim prior to 9.0.0322. | ||||
| CVE-2022-3016 | 2 Fedoraproject, Vim | 2 Fedora, Vim | 2026-11-02 | 7.8 High |
| Use After Free in GitHub repository vim/vim prior to 9.0.0286. | ||||
| CVE-2022-34382 | 1 Dell | 3 Alienware Update, Command Update, Update | 2026-11-02 | 7.8 High |
| Dell Command Update, Dell Update and Alienware Update versions prior to 4.6.0 contains a Local Privilege Escalation Vulnerability in the custom catalog configuration. A local malicious user may potentially exploit this vulnerability in order to elevate their privileges. | ||||
| CVE-2022-32156 | 1 Splunk | 2 Splunk, Universal Forwarder | 2026-11-02 | 8.1 High |
| In Splunk Enterprise and Universal Forwarder versions before 9.0, the Splunk command-line interface (CLI) did not validate TLS certificates while connecting to a remote Splunk platform instance by default. After updating to version 9.0, see Configure TLS host name validation for the Splunk CLI https://docs.splunk.com/Documentation/Splunk/9.0.0/Security/EnableTLSCertHostnameValidation#Configure_TLS_host_name_validation_for_the_Splunk_CLI to enable the remediation. The vulnerability does not affect the Splunk Cloud Platform. At the time of publishing, we have no evidence of exploitation of this vulnerability by external parties. The issue requires conditions beyond the control of a potential bad actor such as a machine-in-the-middle attack. Hence, Splunk rates the complexity of the attack as High. | ||||
| CVE-2022-30164 | 1 Microsoft | 19 Windows 10, Windows 10 1507, Windows 10 1607 and 16 more | 2026-11-02 | 7.8 High |
| Kerberos AppContainer Security Feature Bypass Vulnerability | ||||
| CVE-2022-2982 | 2 Fedoraproject, Vim | 2 Fedora, Vim | 2026-11-02 | 7.8 High |
| Use After Free in GitHub repository vim/vim prior to 9.0.0260. | ||||
| CVE-2022-2980 | 2 Fedoraproject, Vim | 2 Fedora, Vim | 2026-11-02 | 5.5 Medium |
| NULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.0259. | ||||
| CVE-2022-2923 | 2 Fedoraproject, Vim | 2 Fedora, Vim | 2026-11-02 | 5.5 Medium |
| NULL Pointer Dereference in GitHub repository vim/vim prior to 9.0.0240. | ||||
| CVE-2022-2905 | 3 Debian, Linux, Redhat | 3 Debian Linux, Linux Kernel, Enterprise Linux | 2026-11-02 | 5.5 Medium |
| An out-of-bounds memory read flaw was found in the Linux kernel's BPF subsystem in how a user calls the bpf_tail_call function with a key larger than the max_entries of the map. This flaw allows a local user to gain unauthorized access to data. | ||||