Search

Search Results (388997 CVEs found)

CVE Vendors Products Updated CVSS v3.1
CVE-2026-17553 2026-09-09 7.2 High
The WP EasyCart plugin for WordPress is vulnerable to privilege escalation in versions up to, and including, 5.9.3. This is due to the ec_ajax_save_page_default_options() AJAX handler iterating over every $_POST key and passing it directly into update_option() without any allowlist, while gating the handler only on 'manage_options' OR the plugin's custom 'wpec_manager' capability. The plugin's built-in 'wpec_store_manager' role holds 'wpec_manager' but not 'manage_options', and the required nonce is emitted on frontend product/category templates that render for any user with 'wpec_manager'. This makes it possible for authenticated attackers, with Store Manager-level access and above, to elevate their privileges to administrator by updating arbitrary WordPress options such as default_role='administrator' and users_can_register='1', then self-registering a new account that is assigned the administrator role.
CVE-2026-81644 2026-09-09 4.3 Medium
DoS vulnerability in the preview service module. Impact: Successful exploitation of this vulnerability may affect availability.
CVE-2026-49312 2026-09-09 4 Medium
Permission control vulnerability in the window module. Impact: Successful exploitation of this vulnerability may affect service confidentiality.
CVE-2026-49310 2026-09-09 8.6 High
Permission control vulnerability in the event notification module. Impact: Successful exploitation of this vulnerability may affect service confidentiality.
CVE-2026-49314 2026-09-09 7.3 High
OOB write vulnerability in the rendering and composition module. Impact: Successful exploitation of this vulnerability may affect availability.
CVE-2026-49311 2026-09-09 6.2 Medium
Permission control vulnerability in the event notification module.Impact: Successful exploitation of this vulnerability may affect availability.
CVE-2026-58015 2 Gnome, Redhat 10 Glib, Cert Manager, Discovery and 7 more 2026-09-09 5.9 Medium
A flaw was found in GLib. The D-Bus client-side implementation of the DBUS_COOKIE_SHA1 SASL authentication mechanism does not validate the cookie_context parameter received from the server. A malicious D-Bus server can supply a cookie_context containing path traversal sequences, causing the client to read an arbitrary file and exfiltrate sensitive data by verifying guessed file contents against a generated hash.
CVE-2026-58014 2 Gnome, Redhat 10 Glib, Cert Manager, Discovery and 7 more 2026-09-09 7.3 High
A flaw was found in GLib. An off-by-one error can occur in the g_key_file_get_locale_string_list function in the gkeyfile.c file when loading a key file with an empty value. This flaw can cause an out-of-bounds access of 1 byte or a denial of service when the out-of-bounds access crosses a page boundary.
CVE-2026-58013 2 Gnome, Redhat 9 Glib, Cert Manager, Discovery and 6 more 2026-09-09 6.5 Medium
A flaw was found in GLib. A buffer over-read can occur in g_io_channel_read_line_backend() in the giochannel.c file when a custom line terminator with a length greater than one is set, causing memcmp to read past the GString buffer. This vulnerability can cause a minor information disclosure of 7 bytes or a denial of service when the buffer over-read crosses a page boundary.
CVE-2026-58012 2 Gnome, Redhat 9 Glib, Cert Manager, Discovery and 6 more 2026-09-09 6.5 Medium
A flaw was found in GLib. A buffer over-read can occur in the g_regex_replace function when used with the `G_REGEX_RAW` compile flag and case-change replacement escapes because the string_append function processes matched substrings using UTF-8 functions that assume valid UTF-8 input, even when the string is treated as raw bytes. This vulnerability can cause a minor information disclosure of 1-5 bytes and a denial of service when the buffer over-read crosses a page boundary.
CVE-2026-58011 2 Gnome, Redhat 9 Glib, Cert Manager, Discovery and 6 more 2026-09-09 6.5 Medium
A flaw was found in GLib. An out-of-bounds read of only 2 bytes can occur in the g_date_time_get_ymd function in the glib/gdatetime.c file when an invalid GDateTime object produced by the g_date_time_add_full function is processed. This flaw can corrupt the date output and potentially cause logic errors that may lead to a denial of service.
CVE-2026-58010 2 Gnome, Redhat 9 Glib, Cert Manager, Discovery and 6 more 2026-09-09 6.5 Medium
A flaw was found in GLib. An off-by-one error can occur in the gvs_tuple_is_normal function in the glib/gvariant-serialiser.c file when doing an alignment padding check because the bounds check uses > instead of >=, causing an out-of-bounds read of only 1 byte. This issue can cause a minor information disclosure of 1 byte and a denial of service when the out-of-bounds read crosses a page boundary.
CVE-2026-15588 1 Redhat 10 Cert Manager, Discovery, Enterprise Linux and 7 more 2026-09-09 5.3 Medium
A denial-of-service and resource exhaustion vulnerability exists within the `GDBus` component of GLib. The `gdbusauth` authentication mechanism fails to enforce proper length limitations on data lines read from a client. An unauthenticated local or remote attacker can exploit this lack of input validation by sending excessively long streams of data, causing the application to consume massive amounts of system memory and CPU, potentially leading to a crash or system hang.
CVE-2026-11814 1 Netgear 52 Be9300, Be9300 Firmware, Mr60 and 49 more 2026-09-09 6.8 Medium
A command injection vulnerability in the listed NETGEAR models allows a network-adjacent attacker with the ability to intercept and modify local network traffic (attacker-in-the-middle) to compromise the confidentiality and integrity of the affected device. This issue is limited to certain region-specific SKUs.
CVE-2026-11738 1 Netgear 55 Be9300, Be9300 Firmware, Mr60 and 52 more 2026-09-09 4.4 Medium
Insufficient input validation vulnerability in the listed NETGEAR models allows authenticated administrators connected to the local network to make unauthorized modification to router software and functionality.
CVE-2026-9214 1 Netgear 2 R7000, R7000 Firmware 2026-09-09 4.5 Medium
Insufficient input validation vulnerability in the NETGEAR R7000 models allows authenticated administrators connected to the local network to make unauthorized modification to router software and functionality.
CVE-2026-11739 1 Netgear 54 Mr60, Mr60 Firmware, Mr70 and 51 more 2026-09-09 6.4 Medium
A command injection vulnerability in certain affected NETGEAR Nighthawk devices allows a network-adjacent attacker with the ability to intercept and modify local network traffic (attacker in the middle) to compromise the confidentiality and integrity of the affected device.
CVE-2026-11737 1 Netgear 26 Rax20, Rax20 Firmware, Rax41 and 23 more 2026-09-09 4.5 Medium
Insufficient input validation vulnerability in the listed NETGEAR models allows authenticated administrators connected to the local network to make unauthorized modification to the device software and functionality.
CVE-2026-11733 1 Netgear 22 Rax41, Rax41 Firmware, Rax41v2 and 19 more 2026-09-09 4.9 Medium
A buffer overflow vulnerability in the listed NETGEAR models allows a device administrator to temporarily interrupt the normal operation of the affected device.
CVE-2026-11734 1 Netgear 30 Mr70, Mr70 Firmware, Mr90 and 27 more 2026-09-09 2.7 Low
A buffer overflow vulnerability in the listed NETGEAR models allows an authenticated admin user to cause the affected device to become temporarily unavailable.